Kontrola kompatibility šablony vzhledu pro vývojáře – plugin Theme Check

Plugin Theme Check se hodí všem, kdo vytvářejí vlastní šablony pro WordPress, případně si upravují (nebo chtějí použít) starší šablonu v nejnovější verzi WordPressu tak, aby byla plně funkční, tj. obsahovala a podporovala pouze nejnovější funkce WordPressu.

Předem upozorňuji, že využití pluginu je skutečně určeno výhradně pokročilým uživatelům. Méně zkušení mohou na základě analýzy provedené tímto pluginem požádat někoho, kdo to umí, o opravy daného vzhledu.

Pro správnou funkci pluginu je třeba nejprve změnit nastavení souboru wp-config.php na řádku s funkcí WP_DEBUG, opravit hodnotu „false“ na „true“. Soubor, stažený př. prostřednictvím FTP klienta, upravte například v Poznámkovém bloku, nebo v nástroji typu PSPad (zásadně neopravujte ve Wordu atp.) a nahrajte zpět. Se souborem wp-config.php je třeba zacházet obezřetně, je zde nastavena veškerá základní konfigurace!

Řádek k opravě ve wp-config.php:

define(‚WP_DEBUG‘, true);

V menu pluginu pak už stačí v roletkovém menu vybrat danou šablonu vzhledu a spustit kontrolu tlačítkem Check it! Výsledky kontroly, která je založena na principu kontrol, s nimiž jsou schvalovány šablony pro http://wordpress.org/extend/themes/, pak uvidíte hezky v barvách (červené je špatně, zelené je doporučení). Anebo „neuvidíte“, pokud máte šablonu správně odladěnou, pak se dozvíte jen informaci, že šablona v pořádku prošla testy.

Plugin vyžaduje WordPress 3.0 a vyšší, aktualizován byl pro WordPress 3.2.1.

Plugin Theme Check ke stažení:

http://wordpress.org/extend/plugins/theme-check/



Přečtěte si také:



Kategorie : Pluginy, Šablony, WordPress
Štítky:, , , , ,

2 x okomentováno “Kontrola kompatibility šablony vzhledu pro vývojáře – plugin Theme Check”

Přidat komentář (+)

  1. Separatista napsal:

    Bohužel mnoho lidí ještě pořádně nedocenilo všechny potenciální možnosti, které tento plugin poskytuje. Doporučujeme ho zejména klientům, kteří si chtějí nechat udělat šablonu na zakázku. Většinou totiž vůbec netuší v jaké kvalitě vytvořenou šablonu dostanou a mohou si ji tímto způsobem vcelku jednoduše zkontrolovat 🙂 Tento plugin je tak neuvěřitelným „bičem“ na nekvalitní tvůrce šablon a většina z nich vás bude vřele nenávidět, jakmile zjistí, že už nemohou prodávat kopie svých výtvorů založených na zastaralých funkcích WordPressu 2.x a budou muset splňovat současné základní nároky 🙂

Okomentovat

Pro vkládání komentářů musíte být přihlášen/a.