Nutná oprava RSS ve WordPress 2.8.1

Devátého července vývojáři vypustili do světa stabilizovanou verzi WordPress 2.8.1, která dolaďuje novinky z WordPressu 2.8 a je také jakýmsi tradičním „opravným balíčkem“. Aktualizace se doporučuje, není třeba se jí (zřejmě) nijak extrémně obávat, čeština lze použít pro začátek cca stejná jako pro verzi 2.8, ale po přeinstalaci mě velmi nepříjemně překvapila nefunkčnost RSS. Stalo se to navíc u všech webů, kde jsem aktualizaci provedla.

Takže buď je chyba v samotné instalaci nebo nekompatibilita s nějakým mnou všude používaným pluginem. Nicméně problém bylo nutné vyřešit. U WordPressu nic neobvyklého, bohužel… Naštěstí se RSS soubory v zásadě mezi posledními verzemi tolik (pokud vůbec) neliší, a proto bylo možné na RSS aplikovat opravu, o níž jsem psala v tomto článku zde na webu.

Opravené soubory (bez záruky, nicméně u mě funkční) dávám níže k dispozici také ke stažení, přepíší se jimi jednoduše přes FTP soubory ve složce wp-includes a mělo by to být funkční ve verzích WordPress 2.7, 2.7.1, 2.8 a 2.8.1:

Ke stažení:
Oprava RSS ZIP – 6,6 kB



Přečtěte si také:



Kategorie : Užitečné, WordPress
Štítky: , , , ,

2 x okomentováno “Nutná oprava RSS ve WordPress 2.8.1”

Přidat komentář (+)

  1. Pavel Jung napsal:

    Mám podobný problém a nemohu najít řešení. Na http://www.freedlantsko.eu se na zobrazovaném RSS v pravém sloupci nějak vytratila dikaritika. Neřešil někdo tento problém. Nastalo to po přechodu z verze 2.7.1. Děkuji za případné info nebo nápady.

  2. WPress napsal:

    Jak se tak koukám, bude problém s kódováním RSS, odkud zdroj pochází, ten prostřední je UTF-8 (České noviny), stejně jako WordPress, taky jako jediný se ukazuje komplet s háčky a čárkami, pak jsou tam zdroje z idnes a ihned, ty mají kódování windows-1250 a vzniká tam zřejmě nekompatibilita formátů. Proč to dělá zrovna WordPress 2.7.1 netuším, ale po zkušenostech s různými „úpravami“ mezi verzemi mě to ani nepřekvapuje.

    Pokud níže uvedený widget už nepoužíváte a ten problém nevzniká v něm, zkusila bych použít plugin, respektive widget: KB Advanced RSS Widget:

    http://wordpress.org/extend/plugins/kb-advanced-rss-widget/

    Je tam možnost zaškrtnout převádění do UTF, anebo pokud tento plugin používáte a máte zaškrtnuto, zkuste naopak odškrtnout. Jinak nevím, leda jestli by to nesrovnala reinstalace na WordPress 2.8.(2), kde už jsou widgety řešeny v úplně novém systému, takže by to pak mohlo zase začít fungovat…

Okomentovat

Pro vkládání komentářů musíte být přihlášen/a.